An AVX512 capable cpu mandatory for pytorch 2/pytorch-lightning?

Hi,
My computer has a non AVX CPU (xeon x5570). Can a pytorch 2.x based code run on my computer?
Thanks

AVX512 is not mandatory. The minimal assumption is AVX1 I believe.

The default PyTorch binaries are built with AVX1, AVX2 and AVX512 optimizations but AVX512 is gated behind runtime dispatch.

If for some reason you are seeing illegal instruction errors, you can build PyTorch from source.

ho, so AVX is mandatory for pytorch 2. My machine have a non-AVX xeon x5570 CPU.

yea if your processor doesn’t support even AVX1, its too old for PyTorch.