Built-in CUDA not working?

On a fresh install of Ubuntu 16.04 LTS, using the recommended install:

conda install pytorch torchvision cuda80 -c soumith

PyTorch works immediately. But a call to my_tensor.cuda() results in:

Found no NVIDIA driver on your system. Please check that you
have an NVIDIA GPU and installed a driver from

Installing CUDA separately works. But according to this thread it seems that PyTorch’s built in CUDA should work without a separate installation. I’ll be allocating and deallocating many machines running PyTorch, so I just wanted to check if the manual CUDA installation is expected at the moment? Or is there something I’m missing? Thank you!

1 Like

Pytorch comes with its own runtime cuda libraries, but driver has to be installed on each machine separately.

1 Like


what do you mean by “driver has to be installed on each machine separately”. I installed cuda 8 and cudnn 6 and having the same error.

By driver we mean the kernel driver for your graphics card. Are you sure that it is installed and working correctly? You can check the output of nvidia-smi command.

I’m getting this same error with and without installing CUDA separately. I’m completely unable to run pyTorch. Running nvidia-smi gives no errors and says my driver version is 384.98.

Hey, did you find any solution to your problem?