Commandline hangs when trying to use GPU (CTRL+C doesn't kill process)


I’m attempting to use Pytorch on a new Windows machine. I can’t seem to get a working pytorch configuration.

I am using Windows 10 with Nvidia RTX A6000. I have tried several driver versions, cuda versions and pytorch versions in various configurations but I can’t seem to use pytorch.

I don’t get an error message. Instead, any time I try to send anything to the GPU, the commandline freezes completely and CTRL+C doesn’t stop execution, I have to CTRL+Pause/Break to stop execution. For example the line torch.rand(3,3,device=‘cuda:0’) causes the cmd to hang. (but torch.rand(3,3) works fine)

My current software versions are:
graphics driver version 460.89
Cuda 11.1
pytorch 1.8.2

torch.cuda.is_available() returns true
torch.version.cuda returns 11.1

Any ideas of what I should try are appreciated.

Hello, I’ve solved my issue and it was caused by the Windows power performance being set to ‘power saving’. Switching it to ‘high performance’ has allowed me to use pytorch normally.