Compile Pytroch missing python312_d.lib

I already compiled Pytroch with CUDA , CuDnn and distributed support for release but I want to create also the debug build for using it in a project . I’m using the build_pytroch.bat for it . I already found the normal python build with debug symbols means included the python312_d.lib.

The script using mini anconda just copying the files seems doesn’t work and I can’t find the anconda with the debug infos. Also I actually compile it without python support so I’m not sure where it hangs or where I can find the Anaconda with the debug symbols ?

Okay the reason where this problem came from is properly version confusion on my system . I de-installed the other python 3.11 versions and made VC part in the batch file working I mentioned in another script .

Next was cmake which was suddenly on version 3.17 which was too low . Some pointed hardcoded from Visual Studio to old version which weren’t there anymore but with some reinstalling I solved it too . Now the active conda version is/was the one with the old cmake updating caused this :

LibMambaUnsatisfiableError: Encountered problems while solving:

  • package cmake-3.29.0-hf0feee3_0 requires libuv >=1.48.0,<2.0a0, but none of the providers >can be installed

Could not solve for environment specs
├─ cmake 3.29.0** is installable and it requires
│ └─ libuv >=1.48.0,<2.0a0 , which can be installed;
└─ libuv 1.39** is not installable because it conflicts with any installable versions previously reported.

I ignored the dependencies not sure if this works but we will find out

Okay release works again with all. I also solved python312_d.lib problems but it also demand K python312.lib but it gives the error : LINK : fatal error LNK1104: Datei “python312.lib”

Stackoverflow :

This particular issue is caused by specifying a dependency to a lib file that had spaces in its path. The path needs to be surrounded by quotes for the project to compile correctly.

Funny thing I saw compiler errors not recognized compiler options: " " at the beginning. I think there is a bug in the debug cmake settings . It looks for me someone moved the command out of the quotes. I will make bug report when I find the time