Convert_batchnorm_modules does not exist

I am trying to use Opacus to implement DP-SGD, but I cannot find the function “convert_batchnorm_modules” anywhere in the package.
Cannot find answer from google results neither.
Can someone please help me with this? Thanks in advance!

I think convert_batchnorm_modules is deprecated and replaced with ModuleValidator.fix() as described here.

2 Likes

Thank you ptrblck! This is exactly what I need.