convNd pick 2nd instead of 1st element for stride 2

When we use stride, say stride 2, it will pick the 0th, 2nd and so on, is there a way to instead pick 1st, 3rd and so on.

Is there a parameter to conv1d or any other way that will help me get with stride 2 same results as

F.conv1d(t_input, t_weight, padding=5, stride=1)[0,0,1:10:2]

Actual Stride invocation that I am using

F.conv1d(t_input, t_weight, padding=5, stride=2)[0,0,0:5]

The default result that I get is same as

F.conv1d(t_input, t_weight, padding=5, stride=1)[0,0,0:10:2]

I am porting a TF model and somehow the conv there seems to be picking the 1::2 element and torch seems to be picking 0::2. Wanted both model implementations to give same result.

Would it work, if you slice the input starting at index1 in PyTorch? This might not be the most convenient approach, but I don’t think the start index is easily changeable in the backend.

Thanks a lot for the reply, wanted to get an expert’s opinion. If there are no params, will try slicing and other options. Would be great if someone can confirm that the code at least from a intel cpu flow is
F.conv1d → ATen/native/Convolution.cpp → (assuming mkl) ->ATen/native/mkldnn/Conv.cpp → ideep::convolution_forward .