Cuda() failed with "The NVIDIA driver on your system is too old"

I tried to install and use pytorch with a docker container on a gpu server.
When I try to use .cuda() method, it failed with the message:

b = a.cuda()
Traceback (most recent call last):
File “”, line 1, in
File “/root/anaconda3/lib/python3.5/site-packages/torch/_utils.py”, line 51, in _cuda
return self.type(getattr(torch.cuda, self.class.name), async)
File “/root/anaconda3/lib/python3.5/site-packages/torch/_utils.py”, line 24, in type
return new_type(self.size()).copy
(self, async)
File “/root/anaconda3/lib/python3.5/site-packages/torch/cuda/init.py”, line 254, in new
_lazy_init()
File “/root/anaconda3/lib/python3.5/site-packages/torch/cuda/init.py”, line 94, in _lazy_init
_check_driver()
File “/root/anaconda3/lib/python3.5/site-packages/torch/cuda/init.py”, line 77, in _check_driver
of the CUDA driver.""".format(str(torch._C._cuda_getDriverVersion())))
AssertionError:
The NVIDIA driver on your system is too old (found version 8000).
Please update your GPU driver by downloading and installing a new
version from the URL: http://www.nvidia.com/Download/index.aspx
Alternatively, go to: https://pytorch.org/binaries to install
a PyTorch version that has been compiled with your version
of the CUDA driver.

I installed the pytorch with conda and built with the github source as well.
I use ubuntu 14.04, GTX 1080 with driver version of 367.35, CUDA 8.0.44.
Is there any way to run pytorch without updating the driver?
I think 367.35 is enough for CUDA 8 and it worked with torch.

That actually sounds like a docker issue. When PyTorch runs, we check with the CUDA driver API if the driver is sufficient, and we report back what it says…

Are you using NVIDIA-docker? because you need that to run docker images with GPU support.

Thanks for your reply.
I used to run some torch code on a container with nvidia-docker.
Driver version of the server did not make any problem for torch/nvidia-docker.
I will try different images and see what happens.

I have the same problem:
When I use .Cuda() it says:
“The NVIDIA driver on your system is toot old (found version 8000).”

I have a Quadro 3000 M and use Windows 10.
I have already updated the driver but it still doesn’t work