Cudatoolkit 10.0 not found when installing PyTorch via conda


I’m trying to follow the instructions at to install PyTorch on my Ubuntu (16.04) machine. I already have the NVIDIA drivers and CUDA 10.0 set up.

When I attempt to run the command from that page

conda install pytorch torchvision cudatoolkit=10.0 -c pytorch

in a Conda environment, Conda says “PackageNotFoundError: Package missing in current linux-64 channels: - cudatoolkit 10.0*”. What’s wrong?

I just created a new conda env and this command runs successfully on my machine (Ubuntu 18.04).
Could you try to update conda using:
conda update conda
and run the command again?

That updated me from conda 4.3.17 to 4.3.30 and seems to have fixed it, thanks.

Updating conda worked, but I got this

Fetching package metadata …
Solving package specifications: .

And screen froze.

conda can be quite slow when it’s trying to solve the env dependencies, so you could either wait for a bit longer or maybe creating a new virtual conda env and installing PyTorch there could help.

1 Like