I think there’s an error in the documentation for BatchNorm1d. It currently says that num_features is “L from input of size (N,L)”. Shouldn’t it say “C from input of size (N,C)”, as the input shape specification correctly states?
Also, should BatchNorm0d not have its own function? The current API seems confusing since it doesn’t fit the expected pattern of
BatchNorm3d for inputs of shape of shape [C,D,H,W]
Yeah, it might make sense to use the same naming for the num_features and the input documentation. Would you be interested in fixing the docs? If so, feel free to create a GitHub issue with your description of the issue and create the PR after an initial discussion there.
I don’t think it’ll improve the usability of this modules, but let’s see what others think about it.