Found bug in pytorch reinforcement tutorials

hello, i found bug in pytorch reinforcement tutorial, which is on run colab version and it gave me error on this code:
plt.imshow(get_screen().cpu().squeeze(0).permute(1, 2, 0).numpy(),


plt.title(‘Example extracted screen’)
and error says:
Cannot connect to “None”
i haven’t read code what is solution, is that a bug? and how to fix it.To see whole code, you can go to, this is official website.

Which matplotlib version are you using?
Apparently the interpolation argument is not recognized.

i know, like i wrote in question i run the code on google colab.for more info go to the website, where the tutorials are.thanks

please help me, i just started RL, and that bug discouraged me :D.

The error message is still pointing to matplotlib, so which version are you using?

i am using 3.2.0 version.official tutorial uses that version.

Thanks for the information.
In that case I doubt the error is thrown from the posted lines of code but rather from the gym interaction.

thanks, but it is pytorch’s tutorial, i haven’t written any line of code.

I can reproduce the issue on Colab, while the tutorial runs on my local machine.
Could you please open an issue here?

I was facing the same problem so I opened the issue by following your link:

1 Like

abyaadrafid answered on it there on May 30:

!apt install xvfb -y
!pip install pyvirtualdisplay
!pip install piglet

from pyvirtualdisplay import Display
display = Display(visible=0, size=(1400, 900))

using pyvirtualdisplay fixed it for me.

1 Like