How to properly install and utilize torch 1.1.0?

I am installing torchvision, pandas, PIL and other things, here is a glimpse -

!pip install -q pandas
from os.path import exists
from wheel.pep425tags import get_abbr_impl, get_impl_ver, get_abi_tag

platform = '{}{}-{}'.format(get_abbr_impl(), get_impl_ver(), get_abi_tag())
cuda_output = !ldconfig -p|grep|sed -e 's/.*\.\([0-9]*\)\.\([0-9]*\)$/cu\10/'    
accelerator = cuda_output[0] if exists('/dev/nvidia0') else 'cpu'

!pip install -q{accelerator}/torch-1.0.0-{platform}-linux_x86_64.whl torchvision
import torch
!pip install -q Pillow==4.3.0
!pip install -q PIL
!pip install -q image
import PIL

#%reload_ext autoreload        <------------— comment out 
#%autoreload 0                 <------------— comment out
%matplotlib inline

!pip install --no-cache-dir -I pillow

But when I run this, the result is this -

ERROR: torchvision 0.3.0 has requirement torch>=1.1.0, but you’ll have torch 1.0.0 which is incompatible.
ERROR: albumentations 0.1.12 has requirement imgaug<0.2.7,>=0.2.5, but you’ll have imgaug 0.2.9 which is incompatible.
ERROR: Could not find a version that satisfies the requirement PIL (from versions: none)
ERROR: No matching distribution found for PIL

But I have torch 1.1.0 successfully installed -

!pip install -q torch

import torch

The result of the print is 1.1.0. Then why it is showing this result? I am doing all this in google colab. Thanks in advance.

You could use the cmd in the official PyTorch’s website.

Solved, the main problem was in torch vision versions. Just had to update torchvision version to the latest edition.

How did you update torchvision?

pip install torchvision==version or pip install torchvision --upgrade ? For Linux, you can now get torchvision 0.4.0 directly as well with PyTorch-v1.2.0