How to update pytorch using cuda to the most recent version?

I went to:

and in the pytorch forum I was suggested to update but I was not able to for some reason, I think its cuz I dont have root access to the cluster I am using.

Is there any other way to update pytorch to use the latest version?

Which version are you using?
I suppose you would like to install 0.3.1, right?
What kind of error message do you get?

Error msg:


Fetching package metadata .........
Solving package specifications: .
Error: Dependencies missing in current linux-64 channels:
 - pytorch 0.3* -> mkl >=2018
 - pytorch 0.3* -> cudnn 7.0.*

thnx for the help! :smiley:

seems this command helps (idk why if it says nothing about version 2018 in the command):

conda install -c anaconda mkl

Ok so progress. Now I am using pytorch 3 but not 3.1. When I try to force it to install 3.1 it complains with the following:

$ conda install -c pytorch pytorch=0.3.1
Fetching package metadata .........
Solving package specifications: ....

The following specifications were found to be in conflict:
  - pytorch 0.3.1* -> feature:cuda90
  - pytorch 0.3.1* -> feature:cuda91
  - pytorch 0.3.1* -> feature:nccl2
Use "conda info <package>" to see the dependencies for each package.

What cuda version do you have? and did you select the correct cuda version in

of course I selected the correct cuda version. The issue is that it tries to download pytorch: 0.1.12-py36cuda8.0cudnn6.0_1 by itself for some reason rather than 3.1.

Right now I have these:

module list
Currently Loaded Modulefiles:
  1) cuda/8.0         2) cudnn/8.0-v5.1

when I tried updating conda with conda install conda I got the error:

Fetching package metadata .......
Solving package specifications: ..........

Error: ‘conda’ can only be installed into the root environment

Oh, did you create some environments?
Could you deactivate your current environment and try the update again?

Cool that worked (don’t know why…). Now what? Do I activate my old env and try installing pytorch again?

That seemed to work. Why did I need to update conda for the right version of pytorch to get downloaded?

Well, I’m not a conda expert, but I suppose conda had to update its “repositories” to know the new versions of Pytorch. Kind of like with apt-get update, but it’s really a wild guess. :wink:
It’s good to hear, it worked.