Installing torch on the jetson NX

I am trying to download pytorch on a jetson NX to use a tracker i found, problem is that my conda is not able to find the correct cudatoolkit, i’ve trying downloading with pip but when running
torch.cuda.is_available()

i get false
i’ve tried downloading a separate cudatoolkit from another conda channel, and succeeded but when trying to install pytorch without cudatoolkit in the conda command, i get false again when trying to use cuda.
i tried using a different cudatoolkit version (no conda channel seem to have 10.2) and still false.
any help would be appreciated.

after downloading i get this:

print(torch.version)
1.8.1

print(torch.version.cuda)
None

torch.backends.cudnn.enabled
True

i saw a different topic suggesting removing cpuonly, my conda doesnt have it.
I created a completely new environment and did a clean downloaded and still nothing.

as it is a jetson i dont have nvcc or nvidia-smi i can only give you my cuda version which is 10.2.300 which came with the original build of the jetpack.

managed to solve it by following the official Nvidia guide for pytorch on jetson: