Installing torch

I am trying to install torch in linux with cuda version 11.1
I checked this: Start Locally | PyTorch
It says that the code is

pip3 install --user torch==1.9.0+cu111 torchvision==0.10.0+cu111 torchaudio==0.9.0 -f

However, this line gives this error

-f option requires 1 argument

Can someone help?

You are missing the URL after the -f argument:

pip3 install torch==1.9.0+cu111 torchvision==0.10.0+cu111 torchaudio==0.9.0 -f https://download.pytorch.org/whl/torch_stable.html