Issues installing Pytorch and CUDA

Hello, i’m struggling for 2 days to make this work. So i have Geforce GTX 950M, v 388.00 and Python 3.9( i can also do 3.8 if necessary) and Windows 10 and pip for installation. I need home help choosing the right CUDA and pytorch versions for my driver… i tried many combinations but i couldn’t make it work, everytime torch.cuda.is_available() returns False.I checked in Nvidia control panel and it point to CUDA 9.1 version but then i do not know which Pytorch to install, which one is compatible. Many thanks in advance.

The binaries for the current PyTorch release 1.8.1 and the nightly ship with CUDA10.2 and CUDA11.1 as given in the install instructions.

Your local CUDA9.1 installation won’t be used, if you are installing the conda binaries or pip wheels. Also note that you would need a newer NVIDIA driver, since even CUDA9.1 needs >=390.46 based on Table 1.

So i can safely remove the installed CUDA 9.1 from the computer and just install 1.8.1 and CUDA 10.2 / 11.1 (using pip) and work fine?

I tried pip3 install torch==1.8.1+cu111 torchvision==0.9.1+cu111 torchaudio===0.8.1 -f but when it reaches at the end of downloading everything freezes and I cannot do anything( move mouse or type). Is that normal? do I have to wait for it to recover?
Edit:I uninstalled the CUDA 9.1 from machine.
I managed to install using : pip --no-cache-dir install torch==1.8.1+cu111 torchvision==0.9.1+cu111 torchaudio===0.8.1 -f

But now when i try to run the code i receive RuntimeError: CUDA driver initialization failed, you might not have a CUDA gpu. Any idea how to solve this, please?

P.S. I updated the driver and now i have v 398.35 and NVCUDA.dll 9.2. Should I uninstall the above and install something for CUDA 9.2(with pip)?

Your NVIDIA diver seems to be too old, since CUDA11.1 needs driver >= 450.80.02 as described in the linked table.

Many thanks, I managed to fix that problem but I’ve bumped into another issue, if you could take a look, please. Issues training BERT