Linux Mint crashes while vanishing GPU

Hello community.
I started to learn neural networks recently. I’m using pytorch and jupyter notebook as engine for my research application.
I’m trying to learn my nn, using 3CNN and 1FC layers. So, it takes 3.5 GB from 4GB of my laptop GeForce 950M memory to archieve my goal.
The problem is that then i vanish my memory from deprecated notebook, Linux Mint freezes and only reboot helps me to bring it worked again (ctrl+shift_f1 also doesn’t work as well).
How can i fix that? is it hardware problem or pytorch problem?

Best regards,

What do you mean by “vanish my memory”? Are you trying to kill the process to free your memory?

Yes, by clicking shutdown kernel in jupyter notebook or just restart kernel of a notebook

i tried to learn my model one more time and my laptop crashed again. So, then i turned it on, nvidia driver appear that there isn’t GPU card in my laptop. I was frustrated. I switched my OS to win10 and tested GPU unit on it. GPU unit worked fine and benchmark FurMark shown good score.
OK, i switched again on Linux Mint and driver problem disappeared (magic!), but i can’t use gpu memory, then i run pyrotch script that worked fine before! It calls unknown error with pytorch.
What the hell is doing there?
Please, help me.

update: FurMark shown good score on Linux Mint too. It’s not a driver problem i guess.

Best regards,

It seems to be somehow related to your OS.
Could you pose some information of your system?
NVIDIA driver, CUDA version, CuDNN?, PyTorch version

This could help somehow.

What kind of error did you get after running Pytorch again?

$ nvidia-smi
Driver Version: 384.90
GeForce FTX 950M
4042MiB VRAM

$ nvcc --version
release 7.5, V7.5.17

$ torch.version

Is someone can help me?