New to Pytorch, quick question

Hello All

Newbie to pytorch, etc. Please bear with me

nvidia-smi
Fri Dec  8 14:29:51 2023
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 525.147.05   Driver Version: 525.147.05   CUDA Version: 12.0     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  Tesla T4            On   | 00000001:00:00.0 Off |                    0 |
| N/A   31C    P8     9W /  70W |      2MiB / 15360MiB |      0%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|  No running processes found                                                 |
+-----------------------------------------------------------------------------+


On the pytorch website, to install locally, i see either cuda11.8 or 12.1

Which one should I install please? I read all the documents all over the place and am totally confused.

Thanks in advance for your answer and have several nice days ahead

Rajini

Install the binaries with 12.1 if you are using a newer GPU. If you are stuck on e.g. Kepler architectures, use 11.8.