Not install torch 1.4.0 for Windows

hi. i can not install torch 1.4.0 using command pip install torch==1.4.0+cpu torchvision==0.5.0+cpu -f
create error: Could not find a version that satisfiles the requirment torch==1.4.0+cpu (from versions: 0.1.2, 0.1.2post1, 0.1.2.post2)

Do you have the latest pip version? Also which version of python are you using?

Pip 20.0.2 Python 3.6

Have you tried the solution from this other post: Torch version problem ?

On the in the section “Download files” for Version torch 1.4.0 there are No files for Windows.

That’s why there is a -f in the command. So that you use the wheels from this list:
In particular, the one you want is

Do you have a python 32bit by any chance?

I have Python 64 bit.

So the wheel I linked above should work properly for you.

Thank you very much for the help. I used files from the site and I was able to install Version 1.4.0.

1 Like

Which one would work for pip 20.1.1 & Python 3.7.3?

The command from the website should work fine no?

You mean from here?

I specifically need torch 1.4 (for ParlAI), and it looks like that’s not on the “previous versions of PyTorch” page. Maybe I’m just missing something obvious?

In the previous version you have an example command for all versions > 1.0
So just replace the 1.2.0 in the example 1.4.0 should work.

Looking in links:
ERROR: Could not find a version that satisfies the requirement torch==1.4.0+cpu (from versions: 0.1.2, 0.1.2.post1, 0.1.2.post2)
ERROR: No matching distribution found for torch==1.4.0+cpu

After trying:
pip install torch==1.4.0+cpu torchvision==0.4.0+cpu -f

Do you have the latest pip?
Also you will need a 64 bit python. We don’t provide binaries for 32bit python.

Oh, yep, I have 32bit python. I tried it in a virtual environment with 64 bit python and it worked. :woman_facepalming: Thanks!

1 Like