NVIDIA driver version/pytorch error message on Ubuntu 18.04

Hi,

in pycharm IDE I get the following error message:

RuntimeError: The NVIDIA driver on your system is too old (found version 9010). Please update your GPU driver by downloading and installing a new version from the URL: http://www.nvidia.com/Download/index.aspx Alternatively, go to: https://pytorch.org to install a PyTorch version that has been compiled with your version of the CUDA driver.

When I run nvcc --version in the console I get the following:

    nvcc: NVIDIA (R) Cuda compiler driver
    Copyright (c) 2005-2017 NVIDIA Corporation
    Built on Fri_Nov__3_21:07:56_CDT_2017
    Cuda compilation tools, release 9.1, V9.1.85

When I run modinfo nvidia I get this one:

    filename:       /lib/modules/4.15.0-58-generic/updates/dkms/nvidia.ko
    alias:          char-major-195-*
    version:        390.138
    supported:      external
    license:        NVIDIA
    srcversion:     9CF28EA4192CED46A545E30
    alias:          pci:v000010DEd00000E00sv*sd*bc04sc80i00*
    alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
    alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
    depends:        ipmi_msghandler
    retpoline:      Y
    name:           nvidia
    vermagic:       4.15.0-58-generic SMP mod_unload 
    signat:         PKCS#7
    signer:         
    sig_key:        
    sig_hashalgo:   md4
    parm:           NVreg_Mobile:int
    parm:           NVreg_ResmanDebugLevel:int
    parm:           NVreg_RmLogonRC:int
    parm:           NVreg_ModifyDeviceFiles:int
    parm:           NVreg_DeviceFileUID:int
    parm:           NVreg_DeviceFileGID:int
    parm:           NVreg_DeviceFileMode:int
    parm:           NVreg_UpdateMemoryTypes:int
    parm:           NVreg_InitializeSystemMemoryAllocations:int
    parm:           NVreg_UsePageAttributeTable:int
    parm:           NVreg_MapRegistersEarly:int
    parm:           NVreg_RegisterForACPIEvents:int
    parm:           NVreg_CheckPCIConfigSpace:int
    parm:           NVreg_EnablePCIeGen3:int
    parm:           NVreg_EnableMSI:int
    parm:           NVreg_TCEBypassMode:int
    parm:           NVreg_UseThreadedInterrupts:int
    parm:           NVreg_EnableStreamMemOPs:int
    parm:           NVreg_EnableBacklightHandler:int
    parm:           NVreg_RestrictProfilingToAdminUsers:int
    parm:           NVreg_EnableUserNUMAManagement:int
    parm:           NVreg_EnableIBMNPURelaxedOrderingMode:int
    parm:           NVreg_MemoryPoolSize:int
    parm:           NVreg_KMallocHeapMaxSize:int
    parm:           NVreg_VMallocHeapMaxSize:int
    parm:           NVreg_IgnoreMMIOCheck:int
    parm:           NVreg_RegistryDwords:charp
    parm:           NVreg_RegistryDwordsPerDevice:charp
    parm:           NVreg_RmMsg:charp
    parm:           NVreg_AssignGpus:charp

In another post I’ve seen that someone switched the drivers. Does somebody know how this works or has another hint for me?

Your installed NVIDIA driver 390.138 would allow to use CUDA<=9.1 as seen here.
Assuming you’ve installed the PyTorch conda or pip binaries, you would have to update the driver to >=396.26 to use the min. shipped CUDA9.2.