NVIDIA GeForce RTX 3090 with CUDA capability sm_86 is not compatible with the current PyTorch installation

Your install steps focus heavily on installing the CUDA toolkit, which will only be used if you build PyTorch from source or a custom CUDA extension. The pip wheels and conda binaries ship with their own CUDA runtime that you are selecting during the install process.
You would only need to install a proper NVIDIA driver and should be able to use the binaries (unless you want to compile CUDA code and build PyTorch with it or an extension).

Hello @ptrblck :wave: ! So you are saying that I could just install let’s say CUDA 11.6 driver and then install PyTorch pip wheel with proper CUDA 11.6 runtime and that would be enough?

Yes, you would only need to install the NVIDIA driver if you want to execute PyTorch workloads using the binaries.

it works for me, thanks.

I have CUDA 11.7 :slight_smile: nvcc --version
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2022 NVIDIA Corporation
Built on Wed_Jun__8_16:59:34_Pacific_Daylight_Time_2022
Cuda compilation tools, release 11.7, V11.7.99
Build cuda_11.7.r11.7/compiler.31442593_0

But in Pytorch is used 10.2
torch.version.cuda
‘10.2’
installation worked, import works, But when I try torch operations it freezes with:
NVIDIA GeForce RTX 3060 Laptop GPU with CUDA capability sm_86 is not compatible with the current PyTorch installation.
The current PyTorch install supports CUDA capabilities sm_37 sm_50 sm_60 sm_61 sm_70 sm_75 compute_37

It’s Win 10/ 64 bits / NVIDIA 3060/3070

What’s the best to solve this issue, please ?

Install the PyTorch binary with any CUDA11 runtime, as your Ampere GPU won’t work with CUDA10 or older.

I tried that with conda install pytorch torchvision torchaudio pytorch-cuda=11.7 -c pytorch -c nvidia
But in Torch it still showing 10.2:

torch.version.cuda
‘10.2’

Check the install logs if this older version is being installed (it should show you which file is being downloaded and installed) or if the correct PyTorch version is indeed being downloaded but an older one is still installed on your system (in this case uninstall the old PyTorch builds).

Thanks so much! Cleaned all old versions manually (anaconda is bad at cleaning up).

  • upgraded to Py 3.9.15
  • downgraded the Pytorch to be installed from 1.14 to pytorch-1.13.0
    and everything went perfect !
1 Like