Old cuda driver with Pytorch 1.5

Hello all,
I updated my version to 1.5 and keep getting the following error -

AssertionError: 
The NVIDIA driver on your system is too old (found version 10010).
Please update your GPU driver by downloading and installing a new
version from the URL: http://www.nvidia.com/Download/index.aspx
Alternatively, go to: https://pytorch.org to install
a PyTorch version that has been compiled with your version
of the CUDA driver.

Here’s a snapshot of my nvidia-smi

Could someone please guide me what to do
Thanks in Advance

1 Like

Could you post the output of nvcc --version?
Also, how did you install PyTorch? Could you please post the used command?

Thanks for replying @ptrblck

nvcc --version output

nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2019 NVIDIA Corporation
Built on Fri_Feb__8_19:08:17_PST_2019
Cuda compilation tools, release 10.1, V10.1.105

torch was installed with - pip install torch in a virtualenv

Thanks for the information!
I assume you’ve used:

pip install torch==1.5.0+cu101 torchvision==0.6.0+cu101 -f https://download.pytorch.org/whl/torch_stable.html

If that’s not the command you’ve used to install PyTorch, could you please post the one you’ve used?

2 Likes

I just ran

pip install torch

EDIT -
The problem got fixed when I switched drivers from proprietary 435 to 440 open source ones

Hi , I have same issue here

Here is my NVCC version

nvcc: NVIDIA (R) Cuda compiler driver

Copyright (c) 2005-2018 NVIDIA Corporation

Built on Sat_Aug_25_21:08:01_CDT_2018

Cuda compilation tools, release 10.0, V10.0.130

I am installing pytorch 1.2.0 as

conda install pytorch==1.2.0 torchvision==0.4.0 cudatoolkit=10.0 -c pytorch

am I using correct way?

Do you need this old PyTorch version or could you install the latest stable release (1.5.1)?
Which driver and GPU are you using?

OK, Thanks, I think I can try 1.5.1 version

I have the same issue. Here are the versions I have:

pytorch       1.6.0        py3.7_cuda10.1.243_cudnn7.6.3_0    pytorch
cudatoolkit   10.1.243     h6bb024c_0

NVCC:
Cuda compilation tools, release 10.1, V10.1.243

NVIDIA-SMI:
| NVIDIA-SMI 418.126.02 Driver Version: 418.126.02 CUDA Version: 10.1|

Update your driver to the 440 version it should work fine then…

Note: I created a new environment from scratch (with python 3.8 if it matters) and now it works.