Pip install torch==1.9.1+cu111 -f https://download.pytorch.org/whl/torch_stable.html is killed

I am trying to install newest stable torch 1.9.1 witch uses cuda 11.1 (cuda 11.1 and cudnn is already installed and set up). For some reason when I run pip3 install torch==1.9.1+cu111 torchvision==0.10.1+cu111 torchaudio==0.9.1 -f https://download.pytorch.org/whl/torch_stable.html I get the output as follows:

Looking in links: https://download.pytorch.org/whl/torch_stable.html
Collecting torch==1.9.1+cu111
Killed

For some reason this process is killed. I have tried installing torch 1.9.1 which uses cuda 10.2 and it installed successfully. I have also tried installing torch 1.9.1 + cu111 using pycharm’s package handler (using GUI to install) and it worked as well.

Why it only doesn’t work when I try to install it using pip install?

Hi,

This “Killed” means that your computer ran out of ram and so the “pip” command was killed by the OS to save memory.
You should make sure you have enough ram free before running the command.