Processor architecture "armv6l" is not supportec in cpuinfo


I tried to compile pytorch V0.4.0 for raspberry pi zero w and have this warnning message at the beginning of compilation:
CMake Warning at src/ATen/cpu/cpuinfo/CMakeLists.txt:74 (MESSAGE):
Target processor architecture "armv6l" is not supportec in cpuinfo.
cpuinfo will compile, but cpuinfo_initialize() will always fail.
Then after several hours the compilation failed:
[86%]Building CXX object src/ATen/test/CMakeFiles/verify_api_visibiliy.dir/verify_api_visibility.cpp.o
[86%] Linking CXX executable verify_api_visibility
…/ undefined reference to ‘cpuinfo_arm_linux_init’

Would someone help? Thanks very much.

I don’t think you’ll get much support for old versions of PyTorch on new hardware.
You could try with master which generally works on arm. If that gives an error, we can see how to fix it.

Best regards


Hi Thomas,

Thanks for your reply.

I did tried master at first and enconted an error before I decided to try v0.4.0. Unfortunately I don’t remember the error message now. So I will get back here after retrying master.