Protobuf versions for pytorch-2.1.2

In the spack package manager developed by LLNL we need to know the dependencies and their versions for pytorch. Previous versions of pytorch had problems with external protobuf v4, wondering if this is still the case in pytorch-2.1.2?

Issue Numerous builds/tests are broken by protobuf update · Issue #78362 · pytorch/pytorch · GitHub describes the problems and was closed as “mitigated” almost a year ago, but it’s unclear to me if latest versions of pytorch work with protobuf v4. Being limited to v3 is problematic, because many other Python packages require newer versions of protobuf.

If the issue preventing to update to protobuf v4 has not been fixed yet, are there plans (and a timeline) for this to happen?

Thanks!