PyTorch installation error

I’m a total newbie and I’ve got this message below right before finishing PyTorch installation. Can anyone please tell me what is wrong with this?

(base) C:\Users\Ju Hong Min>conda install pytorch cuda91 -c pytorch
Solving environment: done

Package Plan

environment location: C:\ProgramData\Anaconda3

added / updated specs:
- cuda91
- pytorch

The following NEW packages will be INSTALLED:

cuda91:  1.0-0                              pytorch
pytorch: 0.4.0-py36_cuda91_cudnn7he774522_1 pytorch [cuda91]

Proceed ([y]/n)? y

Preparing transaction: done
Verifying transaction: done
Executing transaction: | WARNING conda.gateways.disk:exp_backoff_fn(49): Uncaught backoff with errno EEXIST 17
failed
ERROR conda.core.link:_execute(502): An error occurred while installing package ‘None’.
PermissionError(13, ‘Permission denied’)
Attempting to roll back.

Rolling back transaction: done

PermissionError(13, ‘Permission denied’)
FileExistsError(17, ‘File already exists. Cannot overwrite’)

Did you install conda as admin? The “permission denied” error seems to be pointing to it.
Could you run the terminal as an admin and try it again?

1 Like

@ptrblck Thank you so much. Problem solved. I uninstalled anaconda3 and re-installed the same anaconda3 x64, permission allowed to every user. But still had some other errors (https://github.com/conda/conda/issues/6053 & https://github.com/conda/conda/issues/6286) so I again uninstalled anaconda3 x64 and re-installed anaconda3 x32. This worked for me.