PyTorch no longer supports this GPU because it is too old

Hello, I intend to use PyTorch with Cuda on my machine but I got this error.

Found GPU0 NVIDIA GeForce MX110 which is of Cuda capability 5.0.
    PyTorch no longer supports this GPU because it is too old.
    The minimum Cuda capability supported by this library is 5.2.

I searched this issue on Google, and someone said I should build my own PyTorch from source code. But I don’t know how to make PyTorch work with my GPU. And which parameters should I add to build it? So I post this for help.

Hi @fansuregrin,

You’re most likely going to have to build PyTorch from source, the instructions for this can be found here which will require you to install CUDA, and cuDNN separately as well but it’s all listed out in the instructions. Good luck!

Which PyTorch version are you using? The current binaries should be compatible for all compute capabilities >=3.7.

Thanks for your reply! Unfortunately, I tried to build it from the source but the compiling progress used up all my memory space and my machine got stuck. Obviously, my laptop is not strong enough to do this compiling jod. :frowning:

my pytorch with cuda is version: 1.12.1

memory or storage? Because they are different things, you might need to just clear some space.

1.12.1 should work, as 3.7+ is supported:

>>> import torch
>>> torch.__version__
>>> torch.cuda.get_arch_list()
['sm_37', 'sm_50', 'sm_60', 'sm_70', 'sm_75', 'sm_80', 'sm_86']

Oh, sorry! My English is poor. I mean I only have 12 GB of RAM and it’s not enough.

In my system, my output like this:

>>> import torch
>>> torch.__version__
>>> torch.cuda.get_arch_list()
['sm_52', 'sm_60', 'sm_62', 'sm_70', 'sm_72', 'sm_75', 'sm_80', 'sm_86', 'sm_87', 'compute_87']

By the way, I use Archlinux and the PyTorch package I installed is from this Linux distribution’s official repository. Maybe it’s packager compile it by his own mean. I will try the package from pypi or anaconda.

I solved this problem. I installed pytorch through conda and it can work properly with my gpu.

I don’t know who is building it, but it doesn’t seem to come from us and also shows a different GPU architecture support.
In any case, I would recommend to stick to our pip wheels and conda binaries as they should and are working on your system.