Pytorch on a raberry Pi 4 (32-bit OS)

I tried to install Pytorch on a rasberry PI 4. The OS is the 32-bit from rasberry pi.
I tried it with pip, wheels and building PyTorch from the source. But it didn’t work.

Installing it with wheels, I got always the error that the wheel was not compatible with your currunt version.

@tom provided some PyTorch builds for Raspberry Pi here, which might be useful for you.

The problem with 32bit ARM is that PyTorch cannot be expected to fully work.
Chances are that the compute part works because it is used for android as well, but a long time ago, I noticed that JIT tracing didn’t work on 32bit ARM. As 64bit Raspberry Pi OS is a thing (and will run 32bit things, too), I stopped building and using 32bit PyTorch packages.
Now, this was two years ago and depending on your optimism and constraints you could see if things have improved for 32bit ARM, but personally I would be weary of subtle bugs in PyTorch on 32bit creating debugging headaches.

Best regards