PyTorch v1.0.1 and CUDA 9.2

Hi, I was trying to update to pytorch v1.0.1 via conda, specifically—in a new environment—I am running

conda install -c pytorch pytorch==1.0.1=py3.7_cuda9.0.176_cudnn7.4.2_2 torchvision cudatoolkit=9.2

but this failed because that build of pytorch is expecting cudatoolkit >=9.0,<9.1.

Is cuda 9.2 going to be no longer supported?

FWIW, I have been working with:

conda install -c pytorch pytorch==1.0.0 torchvision cudatoolkit=9.2 

and things have appeared to work fine for the most part (although I have sporadically received some RuntimeError: CUDA error: invalid argument errors, which seem to disappear often upon running the same script again). I believe the conda build that was installed with the last command was py3.7_cuda9.0.176_cudnn7.4.1_1.

The build name suggests that I should use cuda v9.0, but I would like to use cuda v9.2 if possible since the HPC I am running on has CUDA 9.2 drivers. I guess I’m confused about which versions need to be lined up to get correct/optimal performance.

Thanks for the help!