Pytorch with cuda doesn't work - torch.cuda.is_available() false

I’m trying to use pytorch with my GPU but I tried so many things and nothing worked.
I’m working on a desktop windows 10 PC with a NVIDIA GeForce GTX 570. I updated the nvidia driver to the latest version: 391.35
I read that with this graphic card it works the CUDA 9.1
I created a brand new conda environment for trying this with python 3.6. The conda version is 22.9.0.
I installed the pytorch with the cudatoolkit with this command:

conda install pytorch torchvision cudatoolkit=9.0 -c pytorch

But when I run in python this:

import torch

the output is:


Do you have any suggestion? What can I do to may try to solve this problem?
Thank you everyone for the help.


You get this output simply because your graphics card doesnt support CUDA 9.1. Your GPU should support up to CUDA 8.0 as seen here
For more information on that please refer to this stackoverflow post where a thorough explanation is given


thank you for your answer.