Pytorch0.3.1 upadate failed

As you see, I update pytorh to 0.3.1 on Ubuntu16.04,Python3.6,CPU only via Conda.
It shows that the installation was successful.
However, in pycharm, use print(torch.version), 0.3.0 still

As far as I know, pycharm will build a new environment by virtualenv and use it. So you may need to update pytorch in the pycharm environment.

But if I use spyder(anaconda environment), same result.

Could you uninstall all pytorch and torchvision packages and try to reinstall it?

ok,I’ll try it now,thx

I found that the version of pytorch is 0.3.1 in terminal, but in spyder and pycharm it’s 0.3.0 post4

Could you print torch.__path__ in the terminal as well as spyder/pycharm?
Maybe they point to different directories.

I print as you say , they are in the same path.
Thank you

!!! The problem is solved!!
I just used pip uninstall pytorch and then I checked whether it was uninstalled, but I can stil import torch,
so i tried to print version and it is 0.3.1.post2 now
Realy thanks for your help!