RuntimeError: CuDNN error: CUDNN_STATUS_SUCCESS

Have you dealt with the problem?

maybe you can solve the problem with install CUDA 9.2

in my case, the problem was dealt with under below setup
pytorch 0.4.1, CUDA 9.2, and CUDNN 7104

my version of pytorch,cuda and cudnn is official,but it can’t work…

Using https://download.pytorch.org/whl/cu100/torch-1.0.0-cp36-cp36m-linux_x86_64.whl with CUDA 10 fixed it for me.

Hi, can someone tell me how to fix this problem please :

Found GPU0 Quadro K420 which is of cuda capability 3.0.
PyTorch no longer supports this GPU because it is too old.
The minimum cuda capability that we support is 3.5.

RuntimeError: cuDNN error: CUDNN_STATUS_MAPPING_ERROR

with the constraints that it must be compatible with :

conda install -c pytorch pytorch-nightly torchvision cudatoolkit=9.0
pip install torchvision==0.2.2

*without changing CPU

Thanks

I just re-install the whole cuda and cudnn ,
my system env is
pytorch 1.3.0
GPU RTX2080
cuda 10.1
cudnn 7.6.3

Did this issue disappear after reinstalling or are you seeing it now?

yes~ problem solved

I recommand you run

conda remove cudnn cudatoolkit pytorch torchvision

first

I guess the issue is that loading a model trained using a different GPU than RTX, on RTX GPUs for inference or further training. This interoperability between GPUs is not supported. I suspect this issue is due to the generation gap (i.e. RTX is 2000 series instead of 1000 series).

The fix is to trained the model on some RTX GPUs and load it again on RTX gpus. One cannot mix and match and expect it to work without any issues. At least that’s my experience so far.

That’s not the case, as the model’s state_dict is not dependent in any way of the used device (GPU family, CPU, etc.).
What issues have you seen in the past?

For me. I was trying to run a baseline repo. And I had the same issue because I was using RTX GPU which doesn’t work with old pytorch 0.4.1 and possibly cudnn=7.1.2, and it seemed like the virtual env I created for these installations was also broken after doing lots of trial and error.

Solution: I re-started with a clean environment by changing the environment.yaml to have latest pytorch (pytorch=0.4.1 to simply pytorch with no versions) and compatible cuda /cudnn (latest, newer than 9.0/9.2, cudnn=7.1.2 to simply cuddn with no versions).

I too faced the same problem. But it got resolved when I moved from Cuda 9.0 to 9.2

Hello,

It’s doesn’t work for me. What is your python’s version?

Thank you.