The code that was working previously, gets stuck at loading the checkpoint file that is cached on system

Do you know how I could fix this issue? This was working correctly but now it gets stuck at loading the model from cache apparently

(phosa) [jalal@goku phosa]$ python demo.py --filename input/other/bike.jpg --class_name bicycle

2021-05-11 01:33:26,300 INFO     Calling with args: Namespace(class_name='bicycle', filename='input/other/bike.jpg', lw_collision=None, lw_depth=None, lw_inter=None, lw_inter_part=None, lw_scale=None, lw_scale_person=None, lw_sil=None, mesh_index=0, output_dir='output')
2021-05-11 01:33:29,857 INFO     Loading checkpoint from detectron2://PointRend/InstanceSegmentation/pointrend_rcnn_R_50_FPN_3x_coco/164955410/model_final_3c3198.pkl
2021-05-11 01:33:29,864 INFO     URL https://dl.fbaipublicfiles.com/detectron2/PointRend/InstanceSegmentation/pointrend_rcnn_R_50_FPN_3x_coco/164955410/model_final_3c3198.pkl cached in /home/grad3/jalal/.torch/fvcore_cache/detectron2/PointRend/InstanceSegmentation/pointrend_rcnn_R_50_FPN_3x_coco/164955410/model_final_3c3198.pkl

a double-post of running the demo code gets stuck at loading the checkpoint for model_final_3c3198.pkl · Issue #37 · facebookresearch/phosa · GitHub

Assuming you are trying to load a pretrained checkpoint, which can be downloaded again, try to move or delete the cached file and see, if a newly downloaded file would work.

1 Like

Thanks a lot, definitely a great idea. do you know sometimes the cached model breaks even if untouched (for 1-2 weeks)?

hmm it was very weird. I reboot the machine and then I ran it again and it worked.