Updating to latest or recent version using package manager

after updating using the command

conda update pytorch

or uninstalling pytorch and reinstalling with

conda install pytorch torchvision -c pytorch

CosineSimilarity disappears from distance.py.
however it appears that CosineSimilarity remains in the master branch of the source code. Anyone else experiencing this issue?

torch.utils.data.ConcatDataset also disappears…

2 Likes

After manually removing the torch directories and doing a conda uninstall and install the above functions came back, but torch.utils.data.ConcatDataset and all the methods below it in torch.utils.data.dataset source code are still gone…

the issue is that the conda install installs version 0.1.12_1. following the instructions here:

Updating PyTorch

reinstalled version 0.2.0_4. is there any way to get a more up-to-date version short of installing from source?

conda install pytorch=0.3.0 -c pytorch

3 Likes

Thanks, have just tried that and get:

Fetching package metadata …
Solving package specifications:

PackageNotFoundError: Packages missing in current channels:

  • pytorch 0.3.0* -> mkl >=2018

We have searched for the packages in the following channels:

weird. can you try:

conda update -y conda
conda install mkl=2018
conda install pytorch=0.3.0 -c pytorch
2 Likes

thanks, that installed version0.3.0.post4!
as a side note, I had to deactivate the conda environment before running the first 2 commands.

Hi, I after trying conda install pytorch=0.3.0 -c pytorch , I’m getting this error for cuda10-
init__.py", line 56, in

import torch

Traceback (most recent call last):
File “”, line 1, in
File “/home/cy/anaconda3/envs/py36/lib/python3.6/site-packages/torch/init.py”, line 56, in
from torch._C import *
ImportError: libcudart.so.8.0: cannot open shared object file: No such file or directory

I’ve tried

  • conda install -c anaconda cudatoolkit==9.0 and conda install pytorch torchvision cuda92 -c pytorch

Either doesn’t work.

Could I ask, why you are trying to install such an old PyTorch version?
Would you like to execute some legacy code?
If so, I would recommend to install the latest stable version (1.1.0) and create a topic here, in case you get stuck porting your code to the latest version. :wink:

1 Like

porting to 1.1.0 did work with few tweaks. Thanks a mil!

but doesn’t this install version 0.3.0? I thought we wanted to update to the most recent version (from the title of the question).

Can you clarify please?

Thanks in advance!