What version of torch does whisper want? (Raspbian)

Hi, I’m trying to run whisper on Raspbian buster. There are apparently no wheels available for this platform (arm7l). I compiled pytorch from source, but I realised my version (1.0.0) is quite old, so now compiling from the 1.7 branch

The error message from the earlier attempt was:

$ pip install torch===1.0.0 git+https://github.com/openai/whisper.git
Defaulting to user installation because normal site-packages is not writeable
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting git+https://github.com/openai/whisper.git
  Cloning https://github.com/openai/whisper.git to /tmp/pip-req-build-scewa0hz
  Running command git clone --filter=blob:none --quiet https://github.com/openai/whisper.git /tmp/pip-req-build-scewa0hz
  Resolved https://github.com/openai/whisper.git to commit 0b5dcfdef7ec04250b76e13f1630e32b0935ce76
  Preparing metadata (setup.py) ... done
ERROR: Could not find a version that satisfies the requirement torch===1.0.0 (from versions: none)
ERROR: No matching distribution found for torch===1.0.0

I get much the same error if I don’t specify the version.

I ran the setup.py script after building pytorch and it’s imported by python (3.9) when run interactively.

My questions are:

  • how can I get the installer to tell me which version it does want?
  • is it finding any version at all?
  • are there similar version requirements for torchvision, torchaudio, etc?
  • what branch should I be using, 1.7 or master?

I realise this is a lot of questions, but really I’d just be grateful for any info anyone can provide to help me get whisper running on the R-pi. :slight_smile:

EDIT: This thread might help me, but I’d still appreciate any other advice.