Whereis CUDA/Cuda/cuda - Ubuntu 20.4 - cuda install issues

I recently switched from windows to ubuntu. I installed miniconda here, created a virtual environment with python 3.8.5, activated that environment and ran “conda install pytorch torchvision torchaudio cudatoolkit=11.0 -c pytorch”. I ran torch.cuda.is_available() and it says True, but when I run which CUDA/Cuda/cuda or whereis CUDA/Cuda/cuda, I get nothing. nvcc is also not working. I think I might have to update bash file. Would someone please be able to guide me.

Also, Do I need to install cuDNN to work on my ML models using CUDA or is that not needed.

Thank You ! :slight_smile:

The PyTorch conda binaries and pip wheels ship with the specified CUDA (cudnn, NCCL) runtimes, not with a complete CUDA toolkit.
To run PyTorch you would thus not need a local installation of these libraries and could use the binaries directly.
However, if you want to build PyTorch from source, any custom PyTorch extension, or any other CUDA code, you would need to install the CUDA toolkit on your machine.

1 Like