Why I can't use CUDA7.5 when I try to train by GPU using PyTorch

I have installed CUDA7.5,and because my GPU is GeForce so I use CUDA without CUDNN.After I installed PyTorch followed this web’s command,I found I can’t train the mnist model,even with torch.backends.cudnn.enabled=False.
My GPU’s computation capacity is 2.1, I don’t know if the error reason is this
the error is RuntimeError: cuda runtime error (8) : invalid device function at /data/users/soumith/builder/wheel/pytorch-src/torch/lib/THC/generic/THCTensorMath.cu:15
Can you tell me how to solve this problem?Thank you!

Alan,

for your particular GPU, you will have to build pytorch from source. Your GPU is too old to be supported by the binaries.

You can find instructions on how to build from source here:

thank you,i have build it from source and it works now