Windows 11 with Nvidia RTX 4090

Can you please tell me how to use a 4090 RTX GPU for deep learning on Windows 11?
Should I install jupyter notebook ? Or something else in order to run a pythorch code ?
Thank you

You can install the pip wheels or conda binaries from here and could use any IDE or notebooks as you wish. Jupyter notebooks are not a requirement to use PyTorch.

I followed those instructions and , since I choose Pythorch Build → Stable, OS → windows, Package → Pip, language → Python , Compute Platform → 11.7 then I run the command → pip3 install torch torchvision torchaudio --extra-index-url .
Here it says that Pytorch is not supported for windows 11 .
Anyway I entered python command and typed the commands : ```
import torch

but the answer is FALSE.
Why ? Can you please help me to solve this issue ?

I don’t know if Windows 11 is supported and based in the prerequisites:

Supported Windows Distributions

PyTorch is supported on the following Windows distributions:

    Windows 7 and greater; Windows 10 or greater recommended.
    Windows Server 2008 r2 and greater

I would assume it should be supported (I’m not using Windows 11, so cannot test it).

Could you check what the install log showed and what python -m torch.utils.collect_env returns?

Here is the result of the command you suggested

PyTorch version: 1.13.1+cpu
Is debug build: False
CUDA used to build PyTorch: Could not collect
ROCM used to build PyTorch: N/A

OS: Microsoft Windows 11 Pro
GCC version: Could not collect
Clang version: Could not collect
CMake version: Could not collect
Libc version: N/A

Python version: 3.10.9 (tags/v3.10.9:1dd9be6, Dec 6 2022, 20:01:21) [MSC v.1934 64 bit (AMD64)] (64-bit runtime)
Python platform: Windows-10-10.0.22000-SP0
Is CUDA available: False
CUDA runtime version: 12.0.76
GPU models and configuration: GPU 0: NVIDIA GeForce RTX 4090
Nvidia driver version: 528.02
cuDNN version: Could not collect
HIP runtime version: N/A
MIOpen runtime version: N/A
Is XNNPACK available: True

Versions of relevant libraries:
[pip3] numpy==1.24.1
[pip3] torch==1.13.1
[pip3] torch-summary==1.4.5
[pip3] torchaudio==0.13.1+cu117
[pip3] torchvision==0.14.1
[conda] Could not collect

Thanks for the output.
It seems you are installing the CPU-only binary for PyTorch and torchvision while torchaudio uses the binary with the CUDA 11.7 runtime.
Did you see any warnings during the installation where pip was complaining that it couldn’t find the desired package?

It seem no warning. If it is interesting for you, when I give the command echo $CUDA_PATH the answer is blank is empty. Can this be an error?

No, this should not be related since the binaries ship with their own CUDA runtime.
Your local CUDA toolkit will only be used if you build PyTorch from source or any custom CUDA extension.
The issue is caused by:

PyTorch version: 1.13.1+cpu

which shows that the CPU-only version was installed instead of the desired one with +cu117.

If I do this command from the prompt :–>
pip install torch -f

It starts the following command :–>

Downloading (2255.4 MB)

But I supppose that it is not correct . Right?

I’m unsure where you got this command from as the install instructions shows:

pip3 install torch torchvision torchaudio --extra-index-url

for Windows.
In any case, the wheel name looks correct as it contains the cu117 tag in it.
Could you check if you have multiple PyTorch versions installed and uninstall every other before downloading the new one?
Alternatively, create a new virtual environment and install PyTorch there.

How to check multiple pytorch environments? OK. I found the command (pip3 show torch). And nothing was installed.

I have given the command you given me and now torch is installed (version 11.1.0).
Is it right?
I think no.
In fact if I give the command

python -m torch.utils.collect_env

it answers that pytorch PyTorch version: 1.11.0+cpu

Why ?

And also I noticed that CUDA runtime version: 12.0.76.

Is this compatible with my pytorch ?

SOLVED by installing CUDA 17 and pytorch 1.13