Changed to 64bit Python, Still Can't Install Torch

I know this is a common issue but when I try to run the command pip install torch==1.6.0+cpu torchvision==0.7.0+cpu -f, I get the error:

C:\Users\robsa\AppData\Local\Programs\Python\Python39\Scripts>pip install torch==1.6.0+cpu torchvision==0.7.0+cpu -f
Looking in links:
ERROR: Could not find a version that satisfies the requirement torch==1.6.0+cpu (from versions: 0.1.2, 0.1.2.post1, 0.1.2.post2)
ERROR: No matching distribution found for torch==1.6.0+cpu

I was initially using 32bit Python but uninstalled that, and installed Python 3.9 64 bit. I still get the same error.
I have been using MSYS2 to compile C++ code. I think this comes with a version of Python as when I run ‘python -v’ in cmd it shows a lot of file paths pointing to a Python installation inside the MSYS2 folder.

Here is what happens when I run pip -V:

C:\Users\robsa\AppData\Local\Programs\Python\Python39\Scripts>pip -V
pip 20.2.4 from c:\users\robsa\appdata\local\programs\python\python39\lib\site-packages\pip (python 3.9)

Running pip -V from a folder other than scripts:

c:\>pip -V
pip 20.2.4 from C:\msys64\mingw32\lib\python3.8\site-packages\pip (python 3.8)

Cheers for any help in advance!

Did you find anything? I’m facing the same problem.