Compatibility with NVIDIA MX450 graphic card windows

I’m using pytorch version 1.12.1 with CUDA10.2 in windows 10 pro. Is this version of pytorch compatible with NVIDIA MX450 hardware and its driver 528.33? Thank you.

Yes, the mentioned PyTorch release should be compatible with Turing GPUs.

thanks for ur prompt reply. i understand that the pytorch version is compatible. just to clarify, does this line

conda install pytorch==1.12.1 torchvision==0.13.1 torchaudio==0.12.1 cudatoolkit=10.2 -c pytorch

install both cpu and gpu-enabled torch?
im trying to solve this assertion error: torch not compiled with CUDA enabled. so im checking with the community if torch have version compatibility issue with cuda here. thank you!

The install log should show if the CUDA-enabled PyTorch binary or a CPU-only wheel was installed. If you are seeing a cpu tag in the binary name then the CPU-only binary was selected.

hi thanks for the reply. i didnt find the install log for conda, but i came across this under C:\Users\CZ\anaconda3\Lib\site-packages\torch\version.txt

__version__ = '1.12.1'
debug = False
cuda = None
git_version = '664058fa83f1d8eede5d66418abff6e20bd76ca8'
hip = None

is it advisable to install with pip wheels instead of conda? thank you.

Yes, if conda doesn’t find the specified version you might want to try the pip wheels and double check if the cu102 tag is shown in the binary name.

Hi, I have uninstalled anaconda, upgraded cuda to 11.7, and pip installed

pip install torch==1.13.1+cu117 torchvision==0.14.1+cu117 --extra-index-url

in the binary files these exist:


the backend program has successfully run through the part where it used to give assertion error.
however,now it gives a runtime error where torch tries to call a cuda_init function that doesn’t exist.

>>> import torch
>>> x = torch.rand(2,3,device = 'cuda')
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "C:\Users\CZ\AppData\Local\Packages\PythonSoftwareFoundation.Python.3.10_qbz5n2kfra8p0\LocalCache\local-packages\Python310\site-packages\torch\cuda\", line 229, in _lazy_init
RuntimeError: No CUDA GPUs are available

any advice? should i install another version and try again…
thank you

This error point towards a driver issue so make sure your NVIDIA driver is properly installed and can communicate with the GPU.

i have tried these config with my GeForce MX450:

  1. torch 1.13.1+cu117; cuda 11.7; nvidia driver 517.48
  2. torch 1.13.1+cu117; cuda 11.7; nvidia driver 516.01

both throws me the same runtime error: No CUDA GPUs are available.
It should have worked. as far as i know cuda 11.7 is the latest cuda stable version with pytorch, and driver 517.48 & 516.01 are compatible with hardware MX450 and cuda 11.7. any advice?

Unfortunately, I don’t know what might be causing this issue as I’m not a Windows expert.
On my Windows test system I’m using an older MX150 which works properly with torch==1.13.1+cu117 and the current nightly release.

it’s ok. do you advise installing linux to use torch?

Generally yes as I’m only using Linux for years while I only use Windows for a few smoke tests for the latest binary releases to verify the wheels are still working.
Note however, that other users might have a great experience in using Windows and might have a bad experience with Linux systems.