Conda install of pytroch doesn't work

Hello! I created an environment with conda and I want to install pytorch in it, but it doesn’t work. After I get inside my environment with source activate env_name I tried this: conda install pytorch torchvision -c pytorch (I also tried it like this: conda install -c pytorch pytorch torchvision) but I am getting this error:

Using Anaconda Cloud api site
Fetching package metadata: ......
Solving package specifications: ......
Error: Could not find some dependencies for pytorch: mkl >=2018, cudatoolkit >=9.0,<9.1, blas * mkl, cudatoolkit >=10.0,<10.1, cudatoolkit >=9.2,<9.3, blas * openblas, cudnn 7.0.*, cudatoolkit 9.*

Did you mean one of these?

    pytorch, pytorch-gpu, pytorch-cpu

Did you mean one of these?


You can search for this package on with

    anaconda search -t conda cudatoolkit 9.*

 (and similarly for the other packages)

Here are my installed packages:

backports                 1.0                      py34_0  
backports.shutil-get-terminal-size 1.0.0                     <pip>
decorator                 4.0.11                   py34_0  
get_terminal_size         1.0.0                    py34_0  
ipython                   4.2.0                    py34_0  
ipython-genutils          0.1.0                     <pip>
ipython_genutils          0.1.0                    py34_0  
libgfortran               1.0                           0  
numpy                     1.9.2                    py34_0  
openssl                   1.0.2l                        0                   10.0                     py34_0  
pexpect                   4.2.1                    py34_0  
pickleshare               0.7.4                    py34_0  
pip                       9.0.1                    py34_1  
ptyprocess                0.5.1                    py34_0  
python                    3.4.5                         0  
readline                  6.2                           2  
scipy                     0.16.0               np19py34_0  
setuptools                27.2.0                   py34_0  
simplegeneric             0.8.1                    py34_1  
six                       1.10.0                   py34_0  
sqlite                    3.13.0                        0  
tk                        8.5.18                        0  
traitlets                 4.3.1                    py34_0  
wheel                     0.29.0                   py34_0  
xz                        5.2.3                         0  
zlib                      1.2.11                        0  

What should I do? Thank you!

It seems you are using Python3.4. Could you create a new conda environment with Python >= 3.5 and try to install PyTorch again?