Conda not installing or updating to latest pytorch version

I ran this command conda install pytorch torchvision cudatoolkit=10.0 -c pytorch but it was 0.3.0.post4 that got installed. Then I ran conda update pytorch torchvision but got the following message below. How do I update to the latest version of PyTorch? I have a GTX 1080 and the Cuda driver version is 10.1.

Collecting package metadata (current_repodata.json): done
Solving environment: done

==> WARNING: A newer version of conda exists. <==
current version: 4.7.10
latest version: 4.7.12

Please update conda by running

$ conda update -n base -c defaults conda

Package Plan

environment location: /home/kong/anaconda3/envs/ffp

added / updated specs:
- pytorch
- torchvision

The following packages will be downloaded:

package                    |            build
---------------------------|-----------------
libgcc-7.2.0               |       h69d50b8_2         269 KB
pytorch-0.2.0              |py35h01b9ba7_4cu75       311.5 MB  soumith
torchvision-0.1.9          |   py35h72e4c6f_1          87 KB  soumith
------------------------------------------------------------
                                       Total:       311.8 MB

The following NEW packages will be INSTALLED:

libgcc pkgs/main/linux-64::libgcc-7.2.0-h69d50b8_2

The following packages will be SUPERSEDED by a higher-priority channel:

pytorch pytorch::pytorch-0.3.0-py35_cuda8.0.6~ --> soumith::pytorch-0.2.0-py35h01b9ba7_4cu75
torchvision pytorch::torchvision-0.2.0-py35heaa39~ --> soumith::torchvision-0.1.9-py35h72e4c6f_1

Running nvcc -V gives me

nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2019 NVIDIA Corporation
Built on Sun_Jul_28_19:07:16_PDT_2019
Cuda compilation tools, release 10.1, V10.1.243

Could you update conda as given by the command in your output and try to install PyTorch again?