Cuda error: GPU not found

I’m running pytorch with Anaconda Spyder with cuda. This is a windows 10 computer with a GeForce 1050 ti locally but when i run torch.cuda.device_count() console always returns 0. I installed various of cudas like conda install -c anaconda cudatoolkit and other possible versions. However I’m getting the same error always. Is there any possibly solutions I can look into?
Thank you !Annotation%202019-11-04%20100531


Here’s the error trace! The code works fine on Kaggle notebook using GPU, so I’m noy sure why I can’t use my local GPU.

Hi,

The PyTorch version you have downloaded is incompatible with GPU. Uninstall current version fully and install it again using available commands in PyTorch’s website.
But if you are sure about the package, update your Nvidia and cuda driver . You can still check consistent versions in the install page.

Thank you! I will try that !

I have a GeForce 1050 ti, which pytorch/cuda version should i use?

I do not have Nvidia GPU on my own to make sure about solutions.
Could you try this:

conda install pytorch torchvision cudatoolkit=10.1 -c pytorch

But before this make sure you have uninstalled any other previous versions.