cuDNN error with cuda 11.7

Hi everyone. I should run a python program and I should create a VENV as follows:



NVIDIA-SMI 515.86.01
Driver Version: 515.86.01
CUDA Version: 11.7
rtx 3090

I install other packages with

pip install -r requirements.txt

all of the package install successfully.

but when I run that program with below code


I encounter below error.


I think it doesn’t match between cudnn and cuda but I don’t know how to match them.

Or I may be wrong and the error lies elsewhere.

Your installed PyTorch version is 1.0.1.post2 which was built with an older CUDA toolkit and cuDNN version. Also note that the PyTorch binaries ship with their own CUDA runtime dependency and will use these libs. The locally installed CUDA toolkit will be used if you build PyTorch from source or custom CUDA extensions.
Update PyTorch to the latest stable 2.0.0 release and check if you are still seeing the issue, since 1.0.1 was released in early 2019.

Thank you so much for your great guide. My problem was one of the packages named spacy==2.0.18 and I couldn’t install on python 3.10,3.9. With try installing on different version of pythons 3.10,3.9,3.8,3.6 I could install that package on python==3.8 and could install Pytorch=11.7 on it too.