Distributed package doesn't have NCCL built in

There is no error in my pytorch installation, but I am getting such an error, is it because I have only one gpu or is there a solution with a single graphics card?

You might be using Windows, which doesn’t support NCCL, or might have installed the CPU-only binaries. In any case, why do you want to use NCCL with a single GPU? What should the GPU communicate with?

Yes, I am using windows. I tried to do segmentation work with 3D point cloud data, but I encountered this error. Cuda appears but ncll gives false value, I tried reinstalling but the result did not change.

That’s expected as already examined since Windows does not support NCCL. However, you still didn’t answer why you want to use NCCL in the first place with a single GPU?

I’m trying to run a deep learning architecture that does 3d segmentation on windows without using Ubuntu, so I’m trying to use the graphic card.

Thank you for your interest.

You don’t need NCCL to run single GPU workloads, since NCCL is used for multi-GPU communication.