EOFError: Ran out of input (Resnet model)

I’m attempting to train the model myself, I took the code from (GitHub), but when I tried to train the model I got an error.

I run this in a Anaconda Promp: python main.py --config protocols/us8k/esresnet-us8k-stereo-cv1.json --Dataset.args.root D:/Data_Urb8k/Urb8K/Descr_Data/UrbanSound8K/

However, it returns:

I’m sort of stranded on this, unfortunately. Does anyone recognize what could be happening here? I’m assuming some setting on my end doesn’t allow the model to run as I haven’t changed anything in his original code.


The screenshot shows a MemoryError and the EOFError might just be the following error message triggered by the original one. Check if you are running our of memory and if so, reduce the batch size or use lazy loading if not already applied.
PS: you can post code snippets by wrapping them into three backticks ```, which makes debugging easier :wink:

1 Like

when I am training the model, firstly I got loading name_of_data(train=true) after becoming loading name_of_data(train=false), As indicated in the picture