Error using TensorBoard in PyTorch 1.2

I am having the following problem when trying to use TensorBoard in PyTorch 1.2:

 from torch.utils.tensorboard import SummaryWriter 


ImportError: TensorBoard logging requires TensorBoard with Python summary writer installed. This should be available in 1.14 or above.

I understood that I could use TensorBoard with PyTorch 1.2 without problems!

I am using Anconda and I have installed version 1.14 of TensorBoard, so I don’t know what the problem is!!:

tensorboard               1.14.0           py37hf484d3e_0    anaconda
cpuonly                      1.0                0    pytorch
pytorch                       1.2.0             py3.7_cpu_0  [cpuonly]  pytorch
torchvision                 0.4.0             py37_cpu  [cpuonly]  pytorch

I tried with “pip uninstall tb-nightly” but it didn’t work for me. Anyone have the same problem?. I come from Keras / TF and I’m starting with PyTorch (I like PyTorch!!!), so maybe I’m missing out!

I meet the same error as you. I uninstall tensorboard and then install tensorflow, finally it worked. Bless for you! :slight_smile:

It seems that I had some conflict between the TensorBoard of my system (ubuntu 18.04) and the one I had in Anaconda. I reinstalled everything using pip3 (not the anaconda pip3!!) directly and it already works. Thank you a lot. Problem solved!