Error with downloading models and datasets with pytorch

I am trying to download a dataset into my environment with PyTorch and I download cell never finished!

Another piece of information: I am using jupyter notebook with vs.
I think this error happens when I am trying to download a model or dataset and press interrupt.
But when I press restart kernel or run the cell again the cell doesn’t finish downloading!

Are you using HuggingFace’s datasets library? You may get a better response on how to debug if you ask on their forum/GitHub?

No, it’s not Hugging face :pensive:

Maybe the partially downloaded data is corrupt and the Python lib to download it might not be able to detect it properly. Could you check the 'data' folder, delete the CIFAR10 dataset there, and rerun your code? Additionally, try to run the code in a terminal, which might give you more error outputs.

I tried to delete the filed that content the data and tried again with pyrcharm, jupyter notebook, vs but no thing works!
It works Okey in kaggle!

Were you able to download these datasets before on this system? Im wondering if you are running into some permission issue which could disallow Python to download or save files on your workstation.

I was able to download them before!