Failing build mps locally

I followed the instructions for Mac to build mps by putting them in a script

LDFLAGS="-L/usr/local/opt/llvm/lib -Wl,-rpath,/usr/local/opt/llvm/lib"
echo $PATH
python develop

I get errors as follows that implies I have not generated the mps files. Did I miss a step / flag?

RegisterMPS.cpp.o -c /Users/davidradley/pytorch/build/aten/src/ATen/RegisterMPS.cpp

**/Users/davidradley/pytorch/build/aten/src/ATen/RegisterMPS.cpp:635:22:** **error:** **no member named 'abs_out_mps' in namespace 'at::native'**

return at::native::abs_out_mps(self, out);


**/Users/davidradley/pytorch/build/aten/src/ATen/RegisterMPS.cpp:645:70:** **error:** **unknown class name 'structured_acos_out_mps'; did you mean 'structured_acos_out'?**

struct structured_acos_out_mps_functional final : public at::native::structured_acos_out_mps {

Any thoughts?

sorry I have fixed it - I had not cleaned my environment properly

Can you expand more on how exactly you fixed it?

please say more, assume a noob here.

thanks :smiley:

I cant remember exactly - I suspect I had not run

cd ~/pytorch

git submodule deinit -f .

git clean -xdf

python clean

git submodule update --init --recursive

1 Like