FAST AI pytorch windows 10 anaconda 3 issues

My environment details are

windows 10
GPU Compute Capability 3, Nvidia Quadro K1000M
anaconda 3

For running FASTAI tutorials, I built pytorch from source and while running the lesson 1, I am getting following error:

cuda runtime error (48) : no kernel image is available for execution on the device at c:\anaconda2\conda-bld\pytorch_1519501749874\work\torch\lib\thc\generic/

The error refers to a path which is not even there on my system.
What should i do?

GPU CC 3 is not supported anymore. There are three options:

  1. Use legacy PyTorch packages (0.3.1) Not recommend.
  2. Compile it by yourself
  3. Change GPU

I compiled it myself. Even after that no kernel issue is thrown.

Please specify the CUDA CC and try again. See for details.

set TORCH_CUDA_ARCH_LIST=3.0 worked for me. Thanks for pointing it out.

When i ran the FASTAI lesson 1, it gave CUDA Out of memory error. After that i specified bs param and restarted kernel. Now i am able to run the code.