For Previous Version: Conda installs CPU Version only

I am trying to install PyTorch for CUDA 10.2 (or 11.0). However. The latest PyTorch supporting one of my CUDA Versions is PyTorch 1.12.1.
Installing this via Conda with

conda install pytorch==1.12.1 torchvision==0.13.1 torchaudio==0.12.1 cudatoolkit=10.2 -c pytorch

installs the following packages

  cudatoolkit        pkgs/main/win-64::cudatoolkit-10.2.89-h74a9793_1 None
  pytorch            pytorch/win-64::pytorch-1.12.1-py3.7_cpu_0 None
  pytorch-mutex      pytorch/noarch::pytorch-mutex-1.0-cpu None
  torchaudio         pytorch/win-64::torchaudio-0.12.1-py37_cpu None
  torchvision        pytorch/win-64::torchvision-0.13.1-py37_cpu None

These seem to be all CPU Versions and later I get the error messages that my version of torch isn’t compiled with CUDA. I know about this post Installing Pytorch with Conda installs CPU only version so I tried these steps and I even tried to install pytorch with a completly new Conda environment. However I always get the same problem.

Do you have any suggestion on how I can install PyTorch for my CUDA Versions? Or do I need to compile it by myself?

Kind Regards

Actually. I got this now.
The information on the Previous PyTorch Versions | PyTorch seems to be wrong.
The newest PyTorch version supporting my CUDA Versions is: 1.10.1.
I got this idea from browsing
There I realised that there are no CUDA 10.2 Versions for PyTorch 1.12.1.

Installing PyTorch 1.10.1 seems to work fine for me

That’s not the case, as the PyTorch 1.12.1 pip wheels with CUDA 10.2 can be downloaded via your posted link here:

You are kind of right. I forgot to add that I do only have this issue on Windows. But the documentation tells that this should work for Windows and Linux. As you pointed out. There are only precompiled Linux versions.

Just want to add that the official previous version page suggests that conda installation for CUDA 11.3 is available for Pytorch versions as old as v1.8.1, but when one browse through the actual downloadable wheels the oldest version available is actually v1.10.0.

Not sure if this was downloadable in the past but later got removed.